Eclipse User Guide

Notes re using eclipse.

Intended to provide input to https://wiki.linaro.org/Platform/Eclipse/Evaluation.

Maverick i686

  • sudo apt-get install --install-recommends eclipse
  • sudo apt-get install --install-reccomends eclipse-cdt

dpkg --get-selections | grep eclipse
eclipse                                         install
eclipse-cdt                                     install
eclipse-jdt                                     install
eclipse-pde                                     install
eclipse-platform                                install
eclipse-platform-data                           install
eclipse-plugin-cvs                              install
eclipse-rcp                                     install

Attempted to install the yocto plug-in via Help/Install New Software

- requires org.eclipse.rse.terminals.ui 1.0.100 - installed ?from?

- requires org.eclipse.linuxtools.cdt.autotools.core 1.0.0

Tried to get these from http://download.eclipse.org/technology/linuxtools/update

Cannot agree licenses

Bug #593260 Eclipse "Install new software" does not work https://bugs.launchpad.net/eclipse-ubuntu/+bug/593260 suggests installing eclipse-pde

Did so - no change

Somehow the linuxtools got installed without agreeing the licenses

eclipse 3.6 - helios

package in PPA

You may want to track Upgrade eclipse to 3.6

Platform/Eclipse/Evaluation/UserGuide (last modified 2011-11-09 14:24:29)