Installing the Cross Compiler on Ubuntu Lucid or newer released version

There is a PPA with backported toolchain: http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu

They are built from current development packages:

  • binutils-source
  • eglibc-source
  • gcc-4.7-source
  • gcc-4.8-source
  • linux-source
  • armel-cross-toolchain-base
  • gcc-4.7-armel-cross
  • gcc-4.8-armel-cross

They do not give exactly same versions as compilers used in releases for which they are available - please remember about it while doing cross builds.


CategoryHowTo CategoryCrossCompile

WorkingGroups/ToolChain/CrossCompilerOnOlderUbuntu (last modified 2013-08-20 21:25:19)